Author Archives: rudjuk

Google перестает быть бесплатным

Некогда, многие не верили, что Google способен построить что-то стоящее, а не только поисковую машину. Тем не менее, раздавая бесплатные аккаунты и совершенствуя свой сервис, Google добился лидерства на рынке.

Через какое-то время, возникла необходимость вложения в программные средства и инфраструктуру, вложенные в Google окупать, показывать акционерам положительные финансовые результаты.

Вначале, Google окупал свои продукты благодаря рекламе. Со временем, этого стало мало. Начали монетизировать сервисы.

Прослеживаются пути монетизации сервисов Google:

— Вначале была реклама.
— Потом стало платным для тех, кто хочет более 10 адресов.
— Потом стало платным для тех, кто новый.
— Потом стало платным для разработчиков.
— Теперь, стало платным тем, кто работает с Гугл более 10 лет.
— Завтра станет платным ВСЁ.

На данный момент имеем, 1 июля все ранее раздаваемые бесплатные корпоративные аккаунты перестанут поддерживаться и за них будет взиматься стоимость от 10$/аккаунт в месяц. Соответственно, если аккаунтов много, то и много нужно будет платить… Конечно, эта стоимость может повышаться в одностороннем порядке компанией Google.

 

Установка Proxmox на Debian 10

Инструкция по установке:

Установка Proxmox в Debian 10

https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Stretch

 

 

 

 

Как сделать проброс портов на Mikrotik, если он не является шлюзом

Бешенное количество времени потратил на то, чтоб научить Микротик пробрасывать порт, если он не является шлюзом. У меня такое работало в Linux, а Mikrotik и разные «домашние роутеры» не хотели этого делать.  Как оказалось, Mikrotik может всё)))

Для того, чтоб Микротик умел работать с сервером, который работает через другой шлюз, необходимо прописать правила:

В Mangle:

/ip firewall mangle add chain=input action=mark-connection new-connection-mark=to_speedy passthrough=yes in-interface=ether1
/ip firewall mangle add chain=output action=mark-routing new-routing-mark=speedy-isp passthrough=no connection-mark=to_speedy log=no log-prefix=»»
/ip firewall mangle add chain=forward action=mark-connection new-connection-mark=to_speedy-f passthrough=no in-interface=ether1
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=speedy-isp connection-mark=to_speedy-f in-interface=ether1

В Firewall Nat:

/ip firewall nat add chain=srcnat action=masquerade src-address=192.168.20.0/24 log=no log-prefix=»»

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.20.167 to-ports=80 protocol=tcp dst-address=134.249.121.18 in-interface=ether1 dst-port=80 log=no log-prefix=»»
/ip firewall nat add chain=srcnat action=src-nat to-addresses=192.168.20.200 protocol=tcp dst-address=192.168.20.167 dst-port=80 log=no log-prefix=»»


/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.20.167 to-ports=443 protocol=tcp dst-address=134.249.121.18 in-interface=ether1 dst-port=443 log=no log-prefix=»»
/ip firewall nat add chain=srcnat action=src-nat to-addresses=192.168.20.200 protocol=tcp dst-address=192.168.20.167 dst-port=443 log=no log-prefix=»»

Где

134.249.121.18 — внешний адрес WAN Микротика,

192.168.20.200 — внутренний адрес LAN Микротика,

192.168.20.0/24 — внутренняя сеть (LAN),

192.168.20.167 — IP-адрес сервера, к которому пробрасываем порты,

80, 443 — пробрасываемые порты.

 

 

 

Отключение засыпания в Linux Ubuntu, Linux Debian

Отключение какого-либо засыпания в Linux Ubuntu, Linux Debian:

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

Чтобы включить обратно:

sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target

Если это ноутбук и нужно, чтобы он не засыпал при закрытии крышки, тогда добавить в /etc/systemd/logind.conf:

[Login]
HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore

Для применения параметров сделаем

sudo systemctl restart systemd-logind.service

Источник: https://unlix.ru/%D0%BE%D1%82%D0%BA%D0%BB%D1%8E%D1%87%D0%B8%D1%82%D1%8C-%D1%81%D0%BE%D0%BD-%D0%B3%D0%B8%D0%B1%D0%B5%D1%80%D0%BD%D0%B0%D1%86%D0%B8%D1%8E-%D0%B2-debian/

 

 

Linux Ubuntu, Linux Debian сброс настроек графического экрана

Часто бывает, что в Linux Ubuntu или в Linux Debian и в их последователях включается графический режим, который не поддерживается видео-картой или монитором.

В этом случае, переходим в текстовый режим и сбрасываем графические режимы.

Шаг 1:

Замена файла /etc/X11/xorg.conf:

 

 

Section «Device»
Identifier «Configured Video Device»
Driver «vesa»
EndSection

Section «Monitor»
Identifier «Configured Monitor»
EndSection

Section «Screen»
Identifier «Default Screen»
Monitor «Configured Monitor»
Device «Configured Video Device»
EndSection

После этого перезагружаемся.

Если не помогло, переходим к шагу 2.

Шаг 2:

Сносим драйвера:

sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core  xserver-xorg-video-radeon xserver-xorg-video-ati

 

Запрет блокировки экрана на CentOS8

Столкнулся с проблемой блокировки рабочего стола на операционной системе CentOS8. Мало того, что блокировлся экран, так все текущие приложения пользователя завершались. А это проблема для длительно идущих процессов.

Маленький скриптик решил проблему:

cat >no_lock.sh <<'EOD'
#!/usr/bin/bash
#try to prevent screen from locking
killall /usr/bin/xfce4-screensaver
killall /usr/bin/xfce4-power-manager
#no screensaver, blank monitor at 10 minutes, this does not have
#the same problem with mouse focus as if the screensaver kicks in.
xset s off dpms 600 600 600
EOD

После его запуска, удаляется скринсервер и контроль выключения. Сессия работает до перезагрузки сервера.

Автоматическое добавление статических маршрутов после подключения к VPN

В современных версиях Windows есть интересная возможность автоматического добавления статических маршрутов при активации определённого VPN подключения. Когда VPN подключение разрывается, данный маршрут автоматически удаляется из таблицы маршрутизации Windows. Для добавления IPv4 или IPv6 маршрута для VPN подключения используется PowerShell командлет Add-VpnConnectionRoute. Вы конечно, можете вручную в командной строке добавлять нужные маршруты для VPN подключения, но главная проблема в том, что такие маршруты очищаются после отключения от VPN. Поэтому при следующем подключении, вам придется опять  руками прописывать маршруты.

Допустим, вы хотите, чтобы через ваше VPN подключение маршрутизировались только пакеты для двух подсетей (192.168.111.24/ и 10.1.0.0/16), а весь основной трафик должен идти через вашего провайдера.

В современных версиях Windows есть интересная возможность автоматического добавления статических маршрутов при активации определённого VPN подключения. Когда VPN подключение разрывается, данный маршрут автоматически удаляется из таблицы маршрутизации Windows. Для добавления IPv4 или IPv6 маршрута для VPN подключения используется PowerShell командлет Add-VpnConnectionRoute. Вы конечно, можете вручную в командной строке добавлять нужные маршруты для VPN подключения, но главная проблема в том, что такие маршруты очищаются после отключения от VPN. Поэтому при следующем подключении, вам придется опять  руками прописывать маршруты.

Допустим, вы хотите, чтобы через ваше VPN подключение маршрутизировались только пакеты для двух подсетей (192.168.111.24/ и 10.1.0.0/16), а весь основной трафик должен идти через вашего провайдера.

Откройте консоль PowerShell и выведите список всех настроенных VPN подключений в Windows:

Get-VpnConnection

В первую очередь нужно отключить опцию “Use default gateway in remote network” (Использовать основной шлюз в удаленной сети). Это можно сделать в свойствах VPN подключения в панели управления или командой:

Set-VpnConnection –Name workVPN -SplitTunneling $True

Добавим два статических маршрута для нашего VPN-соединения:

Add-VpnConnectionRoute -ConnectionName "workVPN" -DestinationPrefix 192.168.111.0/24 –PassThru
Add-VpnConnectionRoute -ConnectionName "workVPN" -DestinationPrefix 10.1.0.0/16 –PassThru
В параметре DestinationPrefix нужно указать подсеть, или конкретный IP адрес хоста, трафик к которому нужно маршрутизировать через VPN. Для добавления одного IP адреса используйте формат 10.1.1.26/32.

DestinationPrefix : 192.168.111.0/24
InterfaceIndex :
InterfaceAlias : workVPN
AddressFamily : IPv4
NextHop : 0.0.0.0
Publish : 0
RouteMetric : 1

Если у вас активно VPN подключение, вам нужно переподключиться, чтобы новые маршруты добавились в таблицу маршрутизации.

Новые маршруты привязаны к VPN подключению и добавляются при его запуске. Когда вы отключаетесь от VPN сервера, маршруты автоматически удаляются.

Отключитесь от VPN и проверьте таблицу маршрутизации. Маршрут к вашей удаленной сети удалился автоматически, а Get-NetRoute вернет, что маршрут не найден:

Get-NetRoute : No MSFT_NetRoute objects found with property 'DestinationPrefix' equal to '192.168.111.0/24'. Verify the value of the property and retry. CmdletizationQuery_NotFound_DestinationPrefix,Get-NetRoute

Чтобы полностью удалить статических маршрут для VPN подключения, используйте команду:
Remove-VpnConnectionRoute -ConnectionName workVPN -DestinationPrefix 192.168.111.0/24 -PassThru Если вам нужно изменить порядок разрешения DNS имен при активном VPN, познакомьтесь со статьей.

В предыдущих версиях Windows (Windows 7/ Server 2008R2) для динамического добавления маршрутов после установления VPN подключений приходилось использовать CMAK и различные скрипты с командами add route.

Например, можно создать командный файл vpn_route.netsh для добавления маршрутов.

interface ipv4
add route prefix=192.168.111.24 interface="workVPN" store=active
add route prefix=10.1.0.0/16 interface="workVPN" store=active
exit

Данный файл нужно запускать через задание планировщика, которое срабатывает на событие установки VPN подключения в Event Viewer (RasMan 20225)

schtasks /create /F /TN "Add VPN routes" /TR "netsh -f C:\PS\vpn_route.netsh" /SC ONEVENT /EC Application /RL HIGHEST /MO "*[System[(Level=4 or Level=0) and (EventID=20225)]] and *[EventData[Data='My VPN']]"

Источник: https://winitpro.ru/index.php/2021/04/06/dobavlenie-staticheskogo-marshruta-posle-podklyucheniya-k-vpn/

Установка Git

Система синхронизации Git — очень мощная система. И ее работа сильно зависит от того, что Вы указываете в момент установки.

Экспериментальным подходом установлено, что для того, чтоб сертификаты Windows подхватывались и можно было работать без проблем через ssh, необходимо отметить такие галочки при установке:

Исправление поврежденной базы данных MsSQL

Сегодня столкнулся с проблемой запуска базы данных MsSQL. После выключения электричества к ней нельзя подключаться и выдавался статус Suspect.

Решение вопроса:

  1. Перевести базу в статус EMERGENCY:
    EXEC sp_resetstatus ‘yourDBname’;
    ALTER DATABASE yourDBname SET EMERGENCY
  2. Проводим тестирование базы:
    DBCC checkdb(‘yourDBname’)
    ALTER DATABASE yourDBname SET SINGLE_USER WITH ROLLBACK IMMEDIATE
    DBCC CheckDB (‘yourDBname’, REPAIR_ALLOW_DATA_LOSS)
    ALTER DATABASE yourDBname SET MULTI_USER

Источник: https://infostart.ru/1c/articles/59520/

 

 

Включение отладки на серверной стороне в 1С

По умолчанию, при использовании клиент-серверного режима работы 1С-предприятия никакие серверные функции и процедуры не будут поддаваться пошаговой отладке. Система будет выполнять их «на сервере 1С 8.3″, такие процедуры не видны для клиентской машины.

Для включения режима отладки 1С в режиме клиент-сервер достаточно последовать простым инструкциям для каждой версии 1С:

Отладка на сервере для платформы 1С 8.1

  1. Остановить службу 1C Enterprise Server Agent.
  2. Запустить редактор системного реестра. Чтобы открыть редактор реестра, необходимо нажать Windows + R (или Пуск-Выполнить) и ввести в командную строку regedit.
  3. Найти ветку реестра [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\1C:Enterprise 8.1 Server Agent].
  4. Скорректировать атрибут «ImagePath»= , добавив «-debug».
  5. Запустить службу 1C Enterprise Server Agent.

Пример:
До включения:
«C:\Program Files\1cv81\bin\ragent.exe» -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d «C:\Program Files\1cv81\server»
После включения отладки:
«C:\Program Files\1cv81\bin\ragent.exe» -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -debug -d «C:\Program Files\1cv81\server»

Если не работает отладка в 1С 8.2 и 8.3

  1. Остановить службу 1C:Enterprise 8.2 Server Agent.
  2. Запустить редактор системного реестра. Чтобы открыть редактор реестра, необходимо нажать Windows + R (или Пуск-Выполнить) и ввести в командную строку regedit.
  3. Найти ветку реестра [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\1C:Enterprise 8.2 Server Agent\].
  4. Находим свойство «ImagePath»= , добавляем в строку «-debug».
  5. Записываем и запускаем службу.

Пример:
До включения:
«»C:\Program Files (x86)\1cv82\8.2.18.109\bin\ragent.exe» -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d «C:\Program Files (x86)\1cv82\srvinfo»»
После включения отладки:
«»C:\Program Files (x86)\1cv82\8.2.18.109\bin\ragent.exe» -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d «C:\Program Files (x86)\1cv82\srvinfo» -debug»

Источник: https://programmist1s.ru/vklyuchenie-otladki-na-servere-1s/